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A. INTRODUCTION AND OVERVIEW 
 
PTGui (www.ptgui.com) is a commercial stitching tool for creating panorama images of large scenes 
taken with a camera on a tripod. In this application it has to deal with camera rotation and distortions 
caused by lens systems.  

However, with the appropriate settings and handling as described in this quick guide it is a great tool 
for creating mosaic images of microscopic samples, too. Usually, the entire process is done fully 
automatic, and batch processing of created project files is available to enhance efficiency. 
Problematic samples may be manually edited if needed.  

A great advantage of PTGui is the correction of any distortion caused by most microscope and 
camera lenses. Accordingly the pixel/unit-conversion does no more change from image centre to 
image periphery. This is particularly valuable to avoid biases in quantitative image analysis.   

Although I found PTGui extremely efficient, reliable and just amazing for my purposes (e.g. stitching 
microscopic mosaic images of more than 100 sub-images!), I cannot guarantee equal success in any 
other application. 
 
 
 

B. TAKING MICROSCOPIC IMAGES 
 
• Make sure sub-images overlap by at least 15-25% in angiosperms and 30% in conifers. 

• Avoid rotation of the sample while shifting it on the light or object table. Use an X/Y-stage! 

• Keep exposure time and all other sensitivity settings constant for all sub-images of a sample. 
 

http://www.ptgui.com/


PTGui – Quick Guide © Georg von Arx 

1 June 2015 / 8 3 

C. INSTALLING PTGUI 
 

1. Download full [licensed] version from: http://www.ptgui.com/download.html  

2. Run PTGui installer 

3. Launch PTGui; you will be asked to provide the license information to activate the full version; exit 
PTGui when finished. 

4. Download Smartblend-plugin 1 from: http://www.ptgui.com/plugins.html.  

5. Unzip the Smartblend-plugin folder and move it inside the PTGui program folder. 

6. You may want to create a desktop shortcut for PTGui and for the batch stitcher (RunStitcher.exe 
within PTGui program folder). 

 
 
 

D. INITIAL SETUP (BEFORE GETTING STARTED) 
 
-> Navigate to Tools > Options 
 
General-Tab: 
• Check Automatically set panorama filename upon first saving of project 

• Saving > Default folder for new projects: select Same as source images 

• Saving > Default folder for stitched output: select Same as project 
 
Folders & Files-Tab: 
• Standard folder for templates: define a folder of choice 

• Temporary folders: create one to several temporary folders that reside in a partition with plenty of 
free disk space and PTGui can use for memory-intense processes. Check this (these) folder(s) as 
preferred. 
 

Plugins-Tab: 
• Smartblend: browse to the folder containing smartblend.exe and select it. 

 
 
 

E. GETTING STARTED (1ST PROJECT) 
 
1. Launch PTGui 

2. Push the Advanced-button 

3. Load all images of the first stitching project (1. Load images…) 

4. Camera / lens data (EXIF)-window pops up; Push Cancel 2 
-> Option Automatic (use EXIF data from camera, if available) should be unchecked! 

                                            
1 Smartblend evens out slight illumination heterogeneities between the stitched images; it also deals with slight parallax-issues 

when moving the sample around (parallax: shift of an object against the background that is caused by a change in the 
observer's position). 

2 The optics used in the microscope setup differs from the EXIF data (EXchangeable Image Format – extension containing the 
camera settings that were used to take the picture); it is misleading PTGui. 

http://www.ptgui.com/download.html
http://www.ptgui.com/plugins.html
http://www.ptgui.com/plugins.html
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5. Set Focal length to a large number such as “10,000” to “200,000” and Focal length multiplier 
to “1” 3

 

6. Create a preview of the stitched image (2. Align images…) 
-> The Panorama Editor-window pops up after a couple of seconds to one minute; if it doesn’t do 

so, open it manual by going to main menu Tools > Panorama Editor 
-> If no preview of the stitched image is visible, follow instructions in “I. CORRECTING REGISTRATION 

ERRORS, 4.a”).  

7. Go to the Optimizer-tab and select Simple mode 
a) Deselect Optimize lens field of view 
b) Minimize lens distortion select Heavy + lens shift 
c) Push Run Optimizer 
d) The Optimizer Results-window pops up; hopefully it states a very good statistics; push OK 

8. Optional but recommended: improve the quality of the stitched images: 
a) In main menu, navigate to Control Points > Delete Worst Control Points 
b) A process summary window pops up; push OK. 
c) The Optimizer Results-window pops up; hopefully it states a very good statistics; push OK 
d) Optional: Open the Control Point Table (Tools > Control Point Table) and delete Outliers if 

any (Distance much above other control point pairs). 
e) Cycle through a)-d) until you get satisfying statistics (e.g.  Average: <0.8, Maximum: <2.0) 

9. Optional: If you still are not satisfied with the results, follow the instructions in “I. CORRECTING 

REGISTRATION ERRORS” (below) and resume at step 8 or 10 when finished. 

10. Go to the Create Panorama-tab 
a) Set optimum size (button) to Maximum size to obtain an un-resized mosaic image 
b) Choose an appropriate File Format and compression option in Settings 
c) Blend using > Smartblend plugin 
d) Uncheck Use fast transform 

11. In main menu select File > Make Default 
-> Most settings will be automatically applied to future projects as default values 

12. Optional: Go to main menu Project > Calculate Required Temporary Disk Space to check out 
whether you have sufficient disk space available to stitch your project 

13. a) If you want to stitch the image now: 
     Go to the Create Panorama-tab and push Create Panorama-button 
b) If you want to stitch the image later, together with other projects (more efficient, cf. J. BATCH 

PROCESSING): 
     In main menu select File > Save; name the project 

                                            
3 PTGui assumes that all sub-images are taken from a fixed position, i.e. that the camera was rotated around its axes. 

Consequently, peripheral images are assumed to be captured in an acute angle, and PTGui tries to correct for the resultant 
spatial contraction. In the case of microscopic images, the sample was shifted under the microscope for each sub-image, i.e. 
the camera was always perpendicular to the sample (“orthographic projection”). By setting the focal length (distance between 
camera lens and image sensors) to a large value, the rotation assumed by PTGui is reduced to <1°, which virtually eliminates 
any spatial contraction by PTGui.  

 The distortion by the microscope/camera lenses are fully corrected by PTGui 

 See also: http://www.ptgui.com/support.html#5_6 

Playing with the focal length setting (step 5) often improves the automatic pattern matching in case of problems. 
Empirical evidence suggest that – in contrast to expectations from theory – a comparably lower value (e.g. 10,000) 
works better. In this case the automatic pattern matching algorithm may create small distortion. It seems this 
distortion can be removed by re-setting the lens settings: Lens Settings > Advanced: set “a”, “b”, “c”, “d” and “e” to 
“0”. When asked, DO NOT OPTIMIZE THE CONTROL POINTS AGAIN! 

http://www.ptgui.com/support.html#5_6
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F. CREATING PROJECTS (2ND AND FOLLOWING PROJECTS) 
 
1. Launch PTGui or select File > New 

2. Load all images of the first stitching project (1. Load images…) 

3. Create a preview of the stitched image (2. Align images…) 
-> The Panorama Editor-window pops up after a couple of seconds to one minute; if it doesn’t do 

so, open it manual by going to main menu Tools > Panorama Editor 
-> If no preview of the stitched image is visible, follow instructions in ““I. CORRECTING 

REGISTRATION ERRORS, 4.a”).  

4. Go to the Optimizer-tab and select Simple mode 
a) Deselect Optimize lens field of view 
b) Minimize lens distortion select Heavy + lens shift 
c) Push Run Optimizer 
d) The Optimizer Results-window pops up; hopefully it states a very good statistics; push OK 

5. Optional but recommended: improve the quality of the stitched images: 
a) In main menu, navigate to Control Points > Delete Worst Control Points 
b) A process summary window pops up; push OK. 
c) The Optimizer Results-window pops up; hopefully it states a very good statistics; push OK 
d) Optional: Open the Control Point Table (Tools > Control Point Table) and delete Outliers if 

any (Distance much above other control point pairs). 
e) Cycle through a)-d) until you get satisfying statistics (e.g.  Average: <0.8, Maximum: <2.0) 

6. Optional: If you still are not satisfied with the results, follow the instructions in “I. CORRECTING 

REGISTRATION ERRORS” (below) and resume at step 8 or 10 when finished. 

7. Optional: Go to main menu Project > Calculate Required Temporary Disk Space to check out 
whether you have sufficient disk space to stitch your project 

8. Go to the Create Panorama-tab and Set optimum size (button) to Maximum size 

9. a) If you want to stitch the image now: 
     Go to the Create Panorama-tab and push Create Panorama-button 
b) If you want to stitch the image later, together with other projects (more efficient, cf. J. BATCH 

PROCESSING): 
     In main menu select File > Save; name the project 

 
 
 

G. ELIMINATING DISTORTIONS IN SINGLE IMAGES 
 
The following trick removes distortions from single images.  

Note: You must have processed multi-sub-image projects before applying the following procedure! 
Also, the procedure has to be repeated for each optical setup. 

 

1st time: 

1. Open a project with multiple sub-images 

2. Go to the Lens Settings-tab and jot down the values in Lens correction parameters for a-c. 

3. In main menu select File > New 
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4. Load the image of a single-image sample 2× (1. Load images…) 

5. Go to the Lens Settings-tab and paste the values for a-c. Set d and e to 0 

6. Go to the Create Panorama-tab and Set optimum size (button) to Maximum size 

7. In main menu select File > Save; name the project 

8. Optional: you may stitch the image now (cf. F.9a) 

9. Navigate to the project file and copy it to your standard folder for templates (cf. D. SETTING UP 
PTGUI) 

10. Rename the copy of the project file that from now on will serve as a template for stitching single 
images into something sensible, e.g. “Stitch_1_image.pts” 

 

2nd and consecutive times: 

1. Load the image of a single-image sample 2× (1. Load images…) 

2. Go to File > Apply Template and choose the previously created template (e.g. “Stitch_1_image) 

3. Save the project or perform an instant stitching (cf. F.9) 
 
 
 

H. CALIBRATING THE SPATIAL SCALE (PIXEL/UNIT) 
 
For quantitative image analysis the spatial scale (pixels/unit) must be determined. While professional 
microscope-camera systems sometimes provide this information, there are two approaches for low-
budget systems. Although approach 2 may seem more laborious on first sight, it will be more accurate 
and efficient in most cases. 
 

Approach 1: Spatial reference in each (mosaic) image 

1. Capture sub-images of your sample with the desired zoom factor 

2. Create the mosaic image (→ distortions removed) 

3. Measure the extension (in pixels) of the spatial reference with a line measuring tool (e.g., using 
ImageJ) and deduct the pixels/unit conversion 

 
 
 

Approach 2: Using focal length of camera and stage micrometer 

1. Capture two images of stage micrometer (microscope slide with a scale etched on the surface), 
one with the lowest and one the highest camera zoom level 

2. Stitch each of the single images to remove distortions (cf. G. ELIMINATING DISTORTIONS IN SINGLE 

IMAGES) 

3. For each image, measure the distance (in pixels) of two distant divisions on the stage micrometer 
with a line measuring tool (e.g., using ImageJ). 

4. For each image, divide the measured line length (in pixels) by the actual length (in the dimension 
of choice, e.g. microns) → pixel/unit 

5. Repeat steps 3-4 at least 10× to get a robust statistical mean 
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6. For each image, get the focal length (a measure for the zoom level) from the EXIF file 
(EXchangeable Image Format – extension holding the camera settings that were used to take the 
picture; accessible by, e.g. IrfanView) 

7. Use linear interpolation to calculate the pixel/unit-conversion for each intermediate focal length 
(zoom level). 

 
 
 

I. CORRECTING REGISTRATION ERRORS 
 
1. In Panorama Editor-window, select Mode > Edit individual images 

2. Drag and drop individual images to appropriate/corrected locations; if no images are visible, 
directly go to 4. 

3. In PTGui main window, go to Optimizer-tab and push Run Optimizer-button 

4. If you still are not satisfied, you may have insufficient image overlap. One of the following 
strategies should be persued: 

• In Lens Settings-tab, change Horizontal Field of View to 1°, in Panorama Settings-tab, 
change Field of View (both horizontal and vertical) to a multiple of 1° that is large enough to 
contain all sub-images.  

• In PTGui main window, select Control Points > AutoPano to find new control points 4 

• Manual setting of control points in Control Points-tab may help (refer to the help files for 
information on how to do this). Once the manual control points are set, navigate to main menu 
Control Points > Generate Control Points to automatically add additional control points 
based on your manual selection.  

5. When you are satisfied, go back to check list where you left (E.9. or F.6.). 
 
 
 

J. BATCH PROCESSING (STITCHING MULTIPLE IMAGES FROM 
PROJECTS) 

 
1. Launch batch stitcher (RunStitcher.exe) or navigate in PTGui menu bar to Tools > Batch Stitcher 

2. Add all projects you want to stitch; batch stitching initiates automatically 

 Don’t stitch images if you intend to work on your computer at the same time, since stitching uses 
ample system resources! 

 Stitched images are saved under the project name into the folder that contains the project 
 
 
 
 
 

                                            
4 Autopano is an alternative plugin tool for finding control points. Sometimes it performs better than the PTGui algorithms but 

takes more time. 
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K. IMAGE CROPPING (REMOVING DISPENSIBLE IMAGE PARTS) 
 
You may want to crop the output images. I recommend using IrfanView 

(http://www.irfanview.com), because it can handle very large images and will not compress the 
cropped image (alternatively: Photoshop, ImageJ, Image Pro Plus, etc.).  
 
In IrfanView:  
Make sure the plugins package is installed, then: 

a) With left mouse, select crop area 
b) Options > JPG Lossless Crop… (PlugIn) 

 Re-opening and overwriting the cropped image file (File > Save as…) will make the image much 
smaller without loosing any information. It seems that the stitched images still contain the 
information from overlapping planes of the sub-images.  

 
 
 

L. MINIMUM RECOMMENDED COMPUTER PERFORMANCE 
 
 Very large project may require more computer power! 
 
• PC or Mac 
• ≥ 4 MB RAM 
• ≥ 5 GB free disk space 
 
 
 

M. QUESTIONS? 
 
Check the help files and user-group (http://tech.groups.yahoo.com/group/PanoToolsNG) or the 
support/faq site (http://www.ptgui.com/support.html) for specific questions.  

PTGui has a steep learning curve! 

http://www.irfanview.com/
http://tech.groups.yahoo.com/group/PanoToolsNG/
http://www.ptgui.com/support.html
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